BrightSign Supported Devices

Have more questions? Submit a request

The list of supported devices below includes information about the status/compatibility of the signageOS Core App and the specific model.

General Support means that our Core App supports the version of Platform the device is using (like Tizen 2.4, or Android 4.4) and can be used.

Certified model means that our Core App was successfully tested with described FW version and passed all tests. Usually there are at least couple of hundreds of such a device deployed live.

  How To Install SignageOS On BrightSign Display

Step by step guide for device provisioning
Platform Model line General Support Certified model Required FW Version
BrightSign OS 8 LS4 8.0.33 or newer, 8.0.127 is the latest tested
BrightSign OS 8 HD3 8.0.33 or newer, 8.0.127 is the latest tested
BrightSign OS 8 HD4 8.0.33 or newer, 8.0.127 is the latest tested
BrightSign OS 8 XT3 8.0.33 or newer, 8.0.127 is the latest tested
BrightSign OS 8 XT4 8.0.33 or newer, 8.0.127 is the latest tested
BrightSign OS 8 XD3 8.0.33 or newer, 8.0.127 is the latest tested
BrightSign OS 8 XD4 8.0.33 or newer, 8.0.127 is the latest tested
Was this article helpful?
0 out of 0 found this helpful
Share